Total IT - Microsoft 365 – Incident details

Modern Workplace (Microsoft 365, Exchange, SharePoint, Teams, OneDrive, Cloud Continuity) experiencing major outage

Microsoft 365

Resolved
Partial outage 96 %
Started 20 days agoLasted about 9 hours

Affected

Emails

Partial outage from 7:00 AM to 4:07 PM

Managed Cloud

Partial outage from 7:00 AM to 4:07 PM

Modern Workplace (Microsoft 365, Exchange, SharePoint, Teams, OneDrive, Cloud Continuity)

Partial outage from 7:00 AM to 4:07 PM

Updates
  • Resolved
    Resolved

    We have confirmed from Microsoft that this issue has now been resolved.

  • Update
    Update

    As Microsoft continue their mitigation efforts, they have successfully recovered 96% of impacted resources, teams are working on recovering the remaining 4% of impacted customers.

  • Identified
    Identified

    We have an update from Microsoft, they have identified that an issue within the Azure Front Door (AFD) service is causing intermittent access issues to Microsoft 365 portals leading to wider impact. They are reviewing recent changes that may be contributing to the issue and are actively working on mitigation strategies.

  • Investigating
    Investigating

    Microsoft currently have an issue that may affect users access to emails, delayed emails, and authentication errors. Also, access to other Microsoft 365 services may be impacted. 

    Current status: They are looking at diagnostic data to isolate the cause of the issue.