Total IT - Potential Microsoft Outtage – Incident details

Potential Microsoft Outtage

Resolved
Degraded performance
Started 9 months agoLasted about 4 hours

Affected

Managed Cloud

Degraded performance from 8:04 AM to 12:16 PM, Operational from 8:04 AM to 12:16 PM

Hosted Desktop

Operational from 8:04 AM to 12:16 PM

Modern Workplace (Microsoft 365, Exchange, SharePoint, Teams, OneDrive, Cloud Continuity)

Degraded performance from 8:04 AM to 12:16 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

    Crowstrike Outage

    Dear Valued Customers and Partners,

    We are informing you that we are aware of the recent outages affecting Microsoft and CrowdStrike.

    We want to reassure you that all Total IT systems operate normally and remain unaffected by these issues.

    Our Commitment to Stability

    At Total IT, we prioritise the stability and security of our services. Our comprehensive protection platform is designed to mitigate risks and ensure continuous operation. We have conducted thorough tests and ongoing monitoring to confirm that our services are fully operational and secure. 

    Proactive Measures

    Total IT and our supply chain employs a range of proactive measures to maintain service integrity. System architecture and staged rollout of updates are designed to prevent disruptions and ensure seamless service for our customers.

  • Investigating
    Investigating

    We are currently investigating this incident.

    We currently have no reports from any clients or users but as a precaution we are putting all Microsoft Services at risk.