Users may experience delays sending and receiving email messages
Issue ID: EX1144276
Affected services: Exchange Online
Status: Service degradation
Issue type: Incident
Start time: 29 Aug 2025, 11:36 BST - First reported failure to Total IT at 13:58.
Scope of impact
Some users who are located in Europe attempting to send or receive Exchange Online email messages may be impacted.
Root cause
An increase in internal service-to-service calls resulted in authentication failures, causing email delays and failures
Current status
29 Aug 2025, 14:06 BST
After analyzing diagnostic date we determined that excessive internal service-to-service calls resulted in authentication failures, causing email delays and failures. We’re throttling these calls to mitigate the issue and provide relief.
Next update by:
Friday 29 August 2025 at 16:00 BST