Total IT - IMPORTANT: Email Delivery Inbound & Outbound – Incident details

IMPORTANT: Email Delivery Inbound & Outbound

Resolved
Major outage
Started about 1 year agoLasted about 7 hours

Affected

Managed Cloud

Major outage from 9:01 AM to 3:50 PM

Modern Workplace (Microsoft 365, Exchange, SharePoint, Teams, OneDrive, Cloud Continuity)

Major outage from 9:01 AM to 3:50 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We have implemented a workaround and are currently monitoring the situation.

  • Identified
    Identified

    We have identified the vendor that has the issue, and are working closely with them to resolve it.
    Hornet Security that process inbound and outbound emails to remove spam and unsolicited emails currently has an outage.
    They are providing updates via a status portal: status.hornetsecurity.com

  • Investigating
    Investigating

    IMPORTANT We are currently investigating an issue with inbound and outbound email delivery  across multiple clients. We are actively working and triaging with multiple vendors to identify responsibility and rectify the issue. Further updates will be posted  here. We will engage business continuity plans for clients we hold these for and start a workaround process.